Configuring Simple SPAN session
Make sure the destination interface is configured with command:
# switchport monitor
C2950#configure terminal
C2950(config)#
C2950(config)#monitor session 1
source interface fastethernet 0/2
destination interface fastethernet 0/3
no shut
end
C2950(config)#show monitor session 1
STATE SHOULD SHOW UP.
Other Configuration Examples for SPAN
This section includes the following topics:
Configuration Example for a SPAN Session
To configure a SPAN session, follow these steps:
Step 1 Configure destination ports in access or trunk mode, and enable SPAN monitoring.
switch(config)#
interface ethernet 2/5
switch(config-if)#
switchport
switch(config-if)#
switchport mode trunk
switch(config-if)#
switchport monitor
switch(config-if)#
no shut
Step 2 Configure a SPAN session.
switch(config)#
no monitor session 3
switch(config)#
monitor session 3
switch(config-monitor)#
source interface ethernet 2/1-3, ethernet 3/1 rx
switch(config-monitor)#
source interface port-channel 2
switch(config-monitor)#
source interface sup-eth 0 both
switch(config-monitor)#
source vlan 3, 6-8 tx
switch(config-monitor)#
source interface ethernet 101/1/1-3
switch(config-monitor)#
filter vlan 3-5, 7
switch(config-monitor)#
destination interface ethernet 2/5
switch(config-monitor)#
no shut
switch(config-monitor)#
mtu 500
switch(config-monitor)#
rate-limit 10
switch(config-monitor)#
multicast best-effort
switch(config-monitor)#
exit
switch(config)#
show monitor session 3
switch(config)#
copy running-config startup-config
Configuration Example for a Virtual SPAN Session
To configure a virtual SPAN session, follow these steps:
Step 1 Configure destination ports in access or trunk mode, and enable SPAN monitoring.
switch(config)#
interface ethernet 3/1
switch(config-if)#
switchport
switch(config-if)#
switchport mode trunk
switch(config-if)#
switchport trunk allowed vlan add 100-200
switch(config-if)#
switchport monitor
switch(config-if)#
no shut
switch(config)#
interface ethernet 3/2
switch(config-if)#
switchport
switch(config-if)#
switchport mode trunk
switch(config-if)#
switchport trunk allowed vlan add 201-300
switch(config-if)#
switchport monitor
switch(config-if)#
no shut
Step 2 Configure a SPAN session.
switch(config)#
no monitor session 3
switch(config)#
monitor session 3
switch(config-monitor)#
source vlan 100-300
switch(config-monitor)#
destination interface ethernet 3/1-2
switch(config-monitor)#
no shut
switch(config-monitor)#
exit
switch(config)#
show monitor session 3
switch(config)#
copy running-config startup-config
Configuration Example for a SPAN Session with a Private VLAN Source
To configure a SPAN session that includes a private VLAN source, follow these steps:
Step 1 Configure source VLANs.
switch(config-vlan)#
private-vlan primary
switch(config-vlan)#
exit
switch(config)#
interface ethernet 3/1
switch(config-if)#
switchport
switch(config-if)#
switchport access vlan 100
switch(config-if)#
no shut
switch(config)#
interface ethernet 3/2
switch(config-if)#
switchport
switch(config-if)#
switchport mode trunk
switch(config-if)#
switchport trunk native vlan 100
switch(config-if)#
no shut
Step 2 Configure destination ports in access or trunk mode, and enable SPAN monitoring.
switch(config)#
interface ethernet 3/3
switch(config-if)#
switchport
switch(config-if)#
switchport mode trunk
switch(config-if)#
switchport trunk allowed vlan add 100-200
switch(config-if)#
switchport monitor
switch(config-if)#
no shut
Step 3 Configure a SPAN session.
switch(config)#
no monitor session 3
switch(config)#
monitor session 3
switch(config-monitor)#
source vlan 100
switch(config-monitor)#
destination interface ethernet 3/3
switch(config-monitor)#
no shut
switch(config-monitor)#
exit
switch(config)#
show monitor session 3
switch(config)#
copy running-config startup-config
Like this:
Like Loading...
Related